CNC Router upgrades (read)

I have upgraded the computer from the Dell to a small fanless NUC, and updated the Linux distro and upgraded to LinuxCNC 2.8.2.

If this causes any problems, the prior machine is still right there, and we can move the cables back over to it. I MAY have forgotten to tighten the DVI cable going into the monitor so if someone can do that that’d be great.

The operational things to know:
The power switch is on the NUC with a big label pointing to it as shown.

There is no longer any password prompt.
It will start running LinuxCNC automatically upon powerup, so you want the machine’s driver box power on first.
Do not lock the screen, as it takes the admin password to unlock. If it’s locked, just power off the computer and restart it since the login is not required.
All unracking is now done automatically with Home All. Manual unracking against the stops is not needed, nor possible.
Prior to homing, you are in “Joint Mode” and the axes are numbered 0,1,2,3,4 instead of X,Y,Z. You just hit Home All from here anyways, same as before.
You cannot jog the X axis while unhomed (in Joint Mode). You can still jog the Z and Y.

There is no need to turn off the NUC computer when done. It is fanless and does not collect dust inside. You might turn off the monitor. You’ll still need to close LinuxCNC itself when powering down the box.

Nice new improvements:
No login required
Auto-unracking of the gantry
Auto-mounting of your flash drive
When you hit “Open file”, it goes straight to your flash drive directory
Rotary “A” axis is available


UPDATE: problem solved! The error codes were basically telling me to insert my router bit deeper into the router.

I’m at the shop trying to run a CNC program I’ve run several times before on the old system with no problem and the new system is giving me the error codes;

-Linear move on line 4 would exceed Z’s positive limit
-Linear move on line 4 would exceed joint 2’s positive limit
-Invalid params in linear command

I homed the device as usual and set my X,Y and Z to the surface of what I’m cutting. I also tried restarting the computer and the same error codes came up. I’ve googled what those terms mean but I’m not getting solid answers on what I can do.

OK, was it that the G-code is asking Z to go exceedingly high? Or asking for a move in absolute machine coordinates, that Fusion360 sometimes makes for the clearance for rapids?

FYI, for those that are curious, the Z axis is currently numbered in absolute machine coords as Z=0 is the upper limit, and Z= -7.5 inches is the lower limit. That seemed to be a good idea, but maybe not? That almost never comes up because it’s absolute machine coords, but your G-code normally runs relative to the work origin you set with “=0” and it doesn’t matter what range the absolute coords use. However, some CAM software (not VCarve though) can be set so when it retracts for a rapid, isn’t relative to the work Z, but a G53 absolute coordinate move. In this case the program would need to retract to G53 Z0, same as “Safe Z” button does.

The Z-limit is copied over, nothing changed in that regard, as is most of the system. I’d like to be sure I understand what this issue is. I’d ran some G-code through it and saw no issues.

FYI: “joint 2” is just a degree of control before being mapped to the same Z axis. X is composed of Joint 0 and Joint 4 (there’s reasons for the odd numbering), Y is Joint 1, Z is Joint 2, A is Joint 3.

So the second message is just restating the same prob as the first.

“Invalid params in linear command” would also be restating the prob, the param would be the Z coordinate being out of range.

Hello… This is mostly for Danny - but open question for anyone that might be able to answer it. I am trying to use the new linux box - it looks to have power and it’s connected to the monitor - but the monitor is not catching… just a black screen. Anyone know any tricks?

Quick follow up - I did a hard reboot on the new linux box and it works now.

Check that the monitor dvi cable is plugged into the monitor. The screws might not be tightened

It is not supposed to be connected on wifi at all.

The control box needs to be on for Linuxcnc to start. Linuxcnc starts on boot so make sure it’s on first. If not it does a big screen dump. Just power up the box, close the error window and restart Linuxcnc

I haven’t seen the changes, I’m looking forward to them! But I have a few questions. When it un-racks the X axis, does it use both endstop sensors to do it? When I had to physically unrack it, sometimes when I un-rack the machine against the stops, it’s off by about one step. I just want to know how it works, so I can make sure I get the rack 0’ed correctly. If you don’t want to explain it, and just want to tell me what you changed technically, I can google it.

I thought part of the reason why you had people reboot the machine was to ensure all custom settings were cleared out by the linuxcnc startup script.

There are two homing sensors and an offset on the ini file. They start moving in unison until each one finds the switch and backs off.

The switch placement is not high precision, the .ini file contains an offset for one that is like 0.15" of adjusting one side vs the other. That exact number comes from the digital calipers.

Manual unracking is no longer necessary, nor possible as 2.8 does not allow moving synchronized joints in joint mode, i.e. the unhomed state.

There’s restarting Linuxcnc, and rebooting the PC. Restarting Linuxcnc is sufficient.

One reason for shutting down the PC was because the fans took in dust all day. I just changed to a fanless NUC box that doesn’t take in dust, and might be a bit hard for people to find the power button. The box is small and not readily recognized as the PC.

Got a few errors today.
Main error I didnt understand-
Loaded a file and ran a cut path. After the machine stopped, hit start again to re run the same cut. Couldnt get it to start. Tried loading the file agaon, tried loading a different file. Had to close Linux and restart to get it to run a cut again. Pic of the error codes.

First one: you are in Joint mode (unhomed). Movement of synchronized joints only works in world/teleops mode (homed), so you can move Z or Y just not the gantry. Just home-all it. There actually is a way to switch back and forth to joint mode when homed, I’m looking it up. You wouldn’t need to do this, but it would get you out of the mode if you accidentally entered it somehow.

So it got here by reaching the end of the G-code naturally? Not the Stop button? (which shouldn’t put you in Joint mode, but an E-stop might).

“Task mode change” would be to ignore an invalid interpreter command request while already jogging. Examples would be to hit “Run”, “Go to home of current selected axis”, “Safe Z”, or “Probe Z” while currently turning the jog wheel. It will ignore that command as it’s unclear what to do while already executing a move from the jog wheel or keyboard. It shouldn’t have any effect but to just throw out that command as invalid.

Task Mode Change was a recent fix for a bug I reported in 2.8.2., it’s new code. What exactly were you doing to cause the message? Since the fix is new, it’s possible this is a bug with the fix that I need to report, but this message is supposed to show up when intervening to ignore the problematic Task Mode Change.

It happened right after a cut finished. Cut finished, machine retracted, I hit start again.

Yesterday I noticed that the network cable between the CNC and Linux machine doesn’t click into place on the Linux side. I had trouble starting Linux CNC until I jiggled that cable into the Linux box.

1 Like

Yeah, that keeps coming up. But no one has been able to get a new Ethernet cable to the shop to replace it yet. A number of the people that would usually step forward to do something like that haven’t been available.

I figured one would show up pretty quick, but I went ahead and ordered one off Amazon that will be here tomorrow

1 Like

Don’t we have all the materials on hand to makes ethernet cables of any size? I know we have lots of spools on hand. I thought in other threads where this was discussed, that was pointed out. Some who would normally help with this sort of request have been out of town or down with COVID. I thought making ethernet cables was something a lot of members were familiar with, @dannym included.

There is a spool of CAT (?) in the board cube iirc, Where everything else is I have no clue

I think premades are better since the end is molded into the cable, and they’re cheap. Just weird no one came up with one yet and the way the NUC box is sitting it keeps pulling out (the tab on the cable was broken off for a long time, but it almost never pulled out before). I’ll have another cable in hand on Tuesday

There’s still a whole milk crate of pre-made cables in various lengths in the closet.

1 Like

Could someone please help me with referencing the material on the big CNC bed. After pressing “home All” I then zeroed the X, Y and Z points to get the correct XYZ datum points referenced to the piece I was cutting. However, on visualizing on the linux screen, the machine’s reference /oreintation was very different to where the material sat. I eventually managed to get the start point- XY datum start point on the material by putting in an offset of x =0.125 and y= -47.875 (in the vcarve Jobsetup menu). These numbers seem random to me, but were present in the vcarve used by previous user, so presumably someone else had had the same problem).
Has anyone else had issues establishing the X=0 Y=0 datum point reference on their material? I tried different configurations, restarting the linux CNC program, rehoming, moving the datum points to different reference areas on the job set up in vcarve, but could not solve the problem. I just don’t know what I am doing wrong.
I would greatly appreciate any help, ideas /solutions. Thank you!!