Tormach PathPilot computer...died?

Hey All -

Was cutting some aluminum on the Tormach when the computer just turned off mid-cut. The machine still has 220v power. I tried power cycling everything, and did a check of all the plugs. The machine will come out of e-stop and the oiler comes on when you power cycle it, so I believe the hardware is fully functional. The cut that was in progress was only .010 on a .0625 end mill so no reason to think it was overloaded or anything.

The big yellow extension cord seems to have a short in the end, noticeable by just touching it and the lamps for the enclosure flicker. However, nothing I did, plug swapping, etc, would restore power to the controller. I also pulled the controller out and attempted power it up via the button on the case. It seems to be affecting the entire 110v circuit as the computer monitor will not power on either.

I left my stock, end mill and TTS holder in the mill as I didn’t think I’d be able to get it all out without being able to raise the Z axis. If anyone has any ideas how to proceed I’m happy to do the work but beyond getting after it with a multimeter and moving a bunch of stuff around for access to the machine, I’m out of ideas, and I’m afraid it’s non-functional until we resolve this.

1 Like

Thanks for reporting. @EricP or @JoeN any ideas?

1 Like

Also @mgmoore - in regards ghosts in the electrical system


I will get a new receptacle for the extension cord.

1 Like

I’ll be up there tonight to take a look . Possible we could have nuked the power supply when the extension shorted

1 Like

It sounds like a disconnect, not a short. People always confuse the two. A short would blow the circuit breaker – or make visible arcs, start fires, etc… A disconnect seems less likely to have hurt the power supply. More likely the cord is just bad. Try another one.

No idea what would cause an issue with the cord spontaneously. Was anything moved around there? Also, I don’t know if the cord had been tested. Eric ran it originally; I rerouted it later but assumed it was OK otherwise.

Running a proper circuit out the Tormach for 120 V is on the list of things to do. I’ll bump the priority up.

1 Like

I checked the extension cord. It is kind of loose. I checked voltage there. It has voltage. I checked the cord going into this block it has 120v. No power is coming out as far as I can tell. I pulled the monitor power cord and plugged it into a separate power drop and it worked

1 Like

Maybe we can make a twist lock power distro box. We can plug the yellow cord into that. I think it would help in the future

Sorry I couldn’t chase more. I had to leave

1 Like

The flickering lights are probably the looseness of the cord’s outlets. Clearly something else is going on too though.

I will get a proper 120 V run to the Tormach, most likely an outlet box on the corner of the green loft support, though we could maybe do a drop instead.

Just glanced at it so far. Need to open up the front cover and check out that junction box. The Key is pretty sticky.

It is down? It’s not red-tagged on Skedda.

Looked at it a little more yesterday. I pulled the computer power off that distribution block and put it on separate power . Couldn’t get it to power up.
If someone wouldn’t mind verifying this is the case

I have a couple computers that can be harvested for power supplies once we prove this.

I know hardly anything about this machine. Is there anything special hardware-wise about the PathPilot PC? Is it just running Windows? How’s it talk to the Tormach?

There’s nothing special about the computer, it’s just PC hardware. It runs Linux as PathPilot is just really fancy LinuxCNC. I’m planning to come over to the maintenance day tomorrow and I’ll focus on sorting out the exact problem there.


Yep as josh said,
I think it outputs via a DB25 serial to the tormach

I did some more digging. That DB25 is on the “Mesa Card”; it’s not Tormach-custom but I think it’s not quite a regular parallel port either. Newer 1100M and later machines just use an ethernet interface, but our ability to replace or upgrade that PC is limited by the need to support that PCI (e?) card.

Edit: unofficially, we can use a Mesa 6i25 single-lane / low-profile PCIe programmable I/O card. Our existing card may be that or the earlier 5i21 32-bit PCI version. Officially, Tormach sells a nice fanless mini-PC with some kind of ethernet bridge dongle thing to connect to the PCNC1100. At $900 is looks like a nice upgrade in terms of durability, so I wouldn’t spend too much repairing the PC we have.

If it’s a Mesa card, that’s my wheelhouse. They are FPGA, one possible failure mode is losing its flash programming, it’s possible to reflash them.

It doesn’t take a special computer to support an ethernet Mesa card. However, LinuxCNC cannot handle “large” latencies that some BIOS allow, even if rare. It can throw a Following Error and stop the job if it has a latency event. It is annoying but recoverable.

That’s why the CNC router had an older Dell, it was a known low-latency machine that never had a problem. Later I switched to a small, fanless NUC machine but it did have a Following Error a few times and I’m not sure of the cause. I was going to try another PC.

The ethernet is much more desirable than the PCIe IMHO because it doesn’t require all the cabling to go into the PC directly. Much more flexible.

If we want a new PC I’d vote to just buy it from Tormach. We can save a few hundred bucks by building our own, but it’s probably not worth the potential hassle if we ever need tech support on the machine. 50848 - PathPilot Controller for 15L Lathe and PCNC Mills

The install instructions call for mounting the ethernet bridge (which might be from Mesa) by the monitor and running a long DB25 cable into the machine for some reason; we could definitely do better, but that’s implementation details we can worry about when we get there.

@dannym it looks like Tormach’s “PathPilot Controller for 15L and PCNC assembly” could very well be a Mesa 7i92 in an enclosure, but they don’t describe it in any of the docs and I can only find photos showing one end.

Official diagnosis: power supply in the PC released the magic smoke. PC internals appear fine. This has also blown fuse 6 in the control box which is why the power distribution block isn’t working. I just went ahead and ordered both items as they were like $70 and available one-day from Amazon. I’ll bring them over tomorrow and get them installed and we should be back in business.

As a reminder, the key that looks like a key isn’t the key to the control box, it’s the other “broken” one. Lives in the top section of the black toolbox under the clear lid.