[Resolved] Lightburn Can't Connect To Tarkin

Hi All,

I can’t seem to get Lightburn and Tarkin to connect. I tried rebooting, but I can’t seem to get the connection working. “Find My Laser” doesn’t bring any devices up either. Any help is appreciated!

1 Like

Any update on this?

You mentioned rebooting, but I’m not sure if you meant both the PC and the laser itself. If you haven’t tried power cycling the laser via all three switches on the side, maybe try that?

I was trying to power cycle using the top switch. I am heading back later today, so I’ll give it a try on all three switches. Thanks James!

But the LCD panel on the laser lights up, right?

The top switch controls the power to the Ruida controller and that’s the one that matters. The second just switches the light in back and had nothing to do with the system.

I’m standing in front of it now. The remote works, but it is not responding to the arrow keys on the keypad. Don’t know if that’s new or normal. In Lightburn, Tarkin shows as disconnected.

@dannym The LCD panel is on, and all three power buttons on the right are on.

Red tag it immediately if the laser says this:


I feel like the laser room should have some epic movie posters. 2001. Real Genius. Austin Powers. Maybe that’s my inner teenager talking. Anyway, Danny is here looking at it.


Fixed! Thank you Danny!

1 Like

I realized it WAS moving, doing a Frame at glacial speed. To slow to perceive as moving, and Frame mostly suspends other ops.

In Lightburn, Move panel (which wasn’t even active), speed had been changed to 1.3mm/s instead of 100.



Thanks for fixing and explaining the problem @dannym!

1 Like

I sure would like to know who changed that setting and why. Is it time to issue unique logins for each user so we can at least track whodunit?

@dannym thank you for saving the day once again.

This was changed on the panel. It looks all too easy to press “speed” button, then just a “1” on the keypad, and then the machine will appear to freeze up during framing. This may have loaded itself into Lightburn software from the machine’s new hardware setting, I’m not sure.

Unique logins aren’t helpful here. For one, it wouldn’t even require logging into the computer to enter that on the panel. Now if we really wanted to track down the “culprit”, we can, and do, look to Skedda, the security cameras. and/or door logs. But this would be helpful if we found equipment that had been left uncleaned, used equipment outside the rules or other deliberate problems following actual rules. This was just a matter of pressing the wrong button by accident.

If anything, I would blame Ruida for a poor UI, and if I were to write that letter, I’d be up all night.