Pendent Jog Inconsistency - CNC Router

Hey all. I was in this morning cutting a few things on the CNC and I noticed the pendent jog in the counter clockwise direction (75% sure it was counterclockwise) was jittery and inconsistent. The other direction worked normally and when using the arrow keys both x and y were smooth in either direction. All of my programs ran fine but I thought I’d post this just incase it’s a sign of something that needs to be looked at. Also, I did check for the “change battery” light and it was not on.

Yes last night I discovered the manual jog wheel on the mpg was skipping some steps. It does not affect the machine’s ability to run jobs, just not smooth to manually jog from the mpg.

There’s a couple of these controllers now that were damaged and kept for parts, both have good jog wheels so I think we can just swap the wheel

1 Like

Wasn’t the jog wheel encoder, actually. It was something on the PCB. Swapped guts with one with a damaged keypad.

All fixed


Thanks Danny!

The pendant was not usable today in either direction. Skipped more than it didn’t so I think maybe the fix didn’t stay fixed.

OK, now I’m baffled. I first swapped the encoder wheel with an older one and it didn’t fix anything, thus pointing to the board inside the pendant.

I swapped the board and the USB dongle (they have unique IDs programmed into them so a pendant board has to go with its own dongle) and swapped the original encoder back in. That worked just fine.

There is a LinuxCNC message if the USB dongle is unplugged and plugged back in. If there was a USB problem I’d think that would be popping up. It’d be a crazy coincidence if it was consistently jittering until the moment I swapped the boards and then consistently work.

Swapping the encoder wheel with the older one and checking/changing the USB port would be the next step.

Replaced encoder, fixed