Pearl Laser Communications Issue

Sending files (printing) from the Perl PC is just adding them to the print queue and not actually sending the files. Tried restarting the PC, restarting Perl, plugging and unplugging the USB to Parallel cable,

The windows print manager shows the files as queued but with blank status. The printer status in the control panel for the laser shows ready. The Connect option in the print manager is greyed out, The settings (to check and reset the port id) require the admin PIN or password.

Tried all the above steps bother with and without the rotary (my project is rotary.)

Without admin permissions, this is the limit of what I know to do to fix printer communications errors on Windows. If anyone has admin access I’m happy to debug further if you help me.



@dannym @Jordanva2 any ideas on this one?

In the past what worked is by connecting the USB cable in the front of the computer. I believe is the left one, last I looked it was labeled. I believe that computer has an older mother board that does not automatically switch USB or could be the laser itself. Not too savy on that just remember that in the older days you had to specifically assign ports to external hardware and you could not switch connections without switching the port assignment.

Hi, same problem today…read both comments, tried reboot, ensured proper USB plug for computer-laser connection. Job sits in que and goes nowhere. Was hoping to print multiple projects using rotary today. Appreciate any assistance! - Matt

If I were debugging the issue my next step would be to uninstall the device and reinstall it which will make it reset all the saved driver settings. That often unsticks stuck print queues. But you have to be an admin to do that.

I think the port “front left port” issue is a driver issue where the driver saves and reuses the “name” of the USB connection which depends on which port you connect to instead of saving the device id of the connected device and looking for which port matches. I made this same mistake in some software I wrote years ago. So it’s unlikely a new PC would fix that. But that computer is slower than molasses in winter, so a new PC would be a big improvement. If not then try a different USB to Parallel cable or test the cable with a different printer. Maybe hard to lay hands on a printer with a parallel port these days. Or test it with a scope (tedious but doable)

I don’t have a USB to parallel cable but I’ll ask around and see if I can find one. Possibly the driver won’t assign the same LPT number to a different cable so back to needing admin access to change settings. Who would know the admin PIN or password for that PC?

I’ll post if I can find one.

Please don’t attempt to uninstall or reinstall that driver. It won’t help but snowballs the complexity of trying to resolve it.

That cable is a very specific USB-to-parallel cable. Do not try any other cable.

Switching USB ports and clearing the print queue are things to try.

Most often, though, something is wrong with the job itself and it’s either outside the working area entirely, or you’ve accidentally set it to, say, raster a color layer that actually only has vector lines. There is no content in the job and you just get two beeps “job finished” immediately after pressing Play.

Thanks for the info. I won’t pursue reinstalling the driver for the usb-parallel. Do you know the brand/model of cable? Maybe I can locate one of those.

Usually, when you send a job the job name appears on the laser display and that doesn’t happen. The job never changes to the status “sending” in the print manager. In fact, the status stays blank and the job remains in the print manager queue. So I think there is no communication happening. Tries both with the original job for the rotary and again after reboots with a simple job with just a circle in hair line and an enabled vector color. That also failed.

Based on the posts Matt H tried his jobs and they also failed in the same way.

Yep sounds like the print spooler just needs to be reset
sent you admin password. @clayD

Also to note the USB port is assigned in the driver install so only the one works


cable is belkin f5u002. It’s a centronics parallel port, and really the only cable to use.

I did look at it, Device Manager sees the USB device but it does read “printer not found”.

I suspect the centronics ribbon cable stub inside the machine. The pc got placed too far from the machine’s port and it’s been pulled tight

I found and fixed the issue. The port selection in the print manager was unselected.

The check mark by USB002 was not set. Setting that fixed the issue. Maybe someone had unplugged the USB cable and unselected the port because it was no longer there?

1 Like

Posted too soon. The communication issue is fixed. I lasered three cups but 1/3 of the way into the last cup the laser stopped and the green light started blinking. I restarted the laser and resent the design with the design trimmed to where it stopped. It resumed but was slightly misaligned but stopped again 10 minutes further along.

Not sure what’s up and I’m out of time to mess with it.

Probably something in the job.

Thanks so much for all the troubleshooting on this @clayD and for posting your findings here so others can follow along and learn. Hopefully someone can pic up where you left off and find that last piece to this issue.

Could the lid be reading as open?

The interlocks that could interrupt a job would be the coolant pressure and lid. There’s no sensor for overheating or faults from the laser

I tried a couple jobs on pearl earlier just to see how it was faring. My 2-ish-minute jobs all went off without a hitch FWIW.