New Red Laser computer(finally)

We finally were able to upgrade the Red laser computer to a new one! Big thanks to Brian @da5idii for figuring out the right sequence of buttons to make the drivers work on a windows 10 computer.

The printing process for users is the same.
There is no password for the regular user account,

One other thing to note; we only have illustrator on there for the next 24 hours or so as I need to add the login key for Corel still.

Thanks again,


The PC that’s been sitting beside the old red laser PC was the replacement, but the driver wasn’t working, did you fix that one, or get another new one? That PC already had a valid copy of corel on it.

Hi! Did the file prep change at all? I was in there yesterday morning and for some reason the computer would send the file to the laser but none of the paths seemed to be sent. The file name would appear on the lasers screen but the little preview paths wouldn’t show up and running the file would cause the laser to ‘complete’ without doing anything. All my stroke widths and colors were the same as when I used the same file with the old computer.

1 Like

No file prep is the same, the illustrator versions might be slightly different so as always you should copy your old file even if you made it on the computer into a new template. The other thing is for that issue to load a random settings file in public-Laser setting or laser awesomeness then change your settings.( people have been doing weird things to the settings lately I think) and loading a fresh settings fixes that issue. @dsoo

1 Like

Hello Nick and Danny and anyone else having troubles with the Red Laser.

I’m at the shop now, Sunday at 10:14 am, since 9:00 am and have not been able to successfully cut from my files.

The few files I’ve been trying are the same as other successful sessions prior to this visit. The file name shows up in the Red Laser cpu without any line drawings.

Wondering what all I need to change, adjust or tweak to get it to show my artwork for cutting. This issue is new for me.

Thanks for any feedback and tips!
Donna Soo

1 Like

Thanks for your reply and tips Eric.

I copied the line drawing in a new file in Illustrator on the shop desktop, I copied and brought in the brushes settings I created on my laptop; but when I select all of the line art to modify to .001 mm stroke width the artwork disappears and I’m left with the lines that the artwork or ‘brush’ creation that was connected to it. The Red laser cpu does not reveal any line drawings, it is just blank.

Still not able to get it to work for me.

I’m actually not clear on the settings that I need to set going into the illustrator software on the shop computer: like what this entails.

Thanks for pointing out anything else I need to know.


1 Like

I think I use .01mm stroke and it works as expected.

I was able to print/cut from illustrator last night with my regular illustrator files (which I previously imported into Corel)

Check your stroke color to be sure it’s RGB red and not CMYK red?

1 Like

Thanks, Steven, for your feedback and tips!

Eric came by and worked everything over again - Many thanks for Eric’s help! I also rebuilt my file with the correct stroke width from the start using the ‘brushes’ tool in Illustrator since I have a lot of repeating shapes. So, I think between both efforts it is now working for me.

After this success, I did try my originally built file with the incorrect stroke width which I usually change out right before cutting, but the line drawing went blank again. Just a heads up for anyone else who may need to use the ‘brushes’ tool in Illustrator— you may need to have the stroke width set in before you open it on the shop desktop computer if using the ‘brushes’ feature.


1 Like

The Corel License has been logged in, it is the home and student version

we are still working out some kinks with windows 10 printer spooler locking up ,essentially making files not send properly.
Please make sure the laser is fully booted before you try to send any files,

Also although the manual is not perfect/formatted nicely it can be helpful for a lot of people (Scan the QR code on the machine and click under manuals to get to the google doc.


Thanks Eric

1 Like

I looked like there were two different Corel versions installed - could the “wrong” one be removed to avoid confusion?

(And the right one added to the taskbar/toolbar/shortcuts?)

I uninstalled the other one and pinned the stuff as you requested. Thanks for the suggestion.

It looks like someone printed with the laser off and locked up the spooler.
I posted it on the monitor but everyone Please make sure the laser is fully booted up before attempting to send a job from the computer.
It seems like windows 10 is far less forgiving when this happens.


1 Like


For future reference (here on the forum) - what are they symptoms of the spooler being locked up?

Is there an easy resolution or does this require an admin person to fix?

If you send a print job with the laser off, then the job will stay stuck in the print spooler. It will not auto-send once the laser is turned on. All successive print jobs will queue up behind the stopped job and nothing will happen. Rebooting the PC will NOT clear this. Telling the job to Resume/Resend or whatever didn’t help in Windows 7 and I don’t expect it to help in Windows 10.

You can open the print queue and delete all the pending jobs. At best, this may take an unexpectedly long time- perhaps minutes. In some cases, it doesn’t seem cases, they seem to stick around in the “deleting…” state indefinitely.

In that case you need to stop and restart the print spooler. Just google “restart print spooler Windows 10” and grab something like this:

run services.msc
print spooler->STOP
print spooler->RESTART

the print spooler will then work as long as Red is powered up

Yeo @okyeron @dannym that is essentially the procedure check the print queue and restart the spooler as danny described above.
currently the user account on the computer does not allow access to stop/restart the spooler so that is something @da5idii or I will have to add to the permissions over the next week or so.