Mill DRO malfunctioning?

I tried using the mill the other day, and the X direction on the DRO seems to be working, but the Y direction (The direction without the power feed) seems to jump around. It seems like the encoder is flaking out. I ended up just using a micrometer to measure the table position and that worked out just fine, but was wondering if there’s a way to clean the encoder, recalibrate it or something?

Also, as a unrelated question… if I want to cut an angled side into a part (so it’s not parallel to the opposite side)… what’s the best way to do it without the DRO? (I get how to do it with the DRO, and with a bit of fiddling, I can probably find a spot on the encoder strip that behaves…) Do you just mount the vice at an angle? I don’t want to move the one that’s squared in, but there’s a second vice there that’s not bolted into position, but it seems to have protrusions on the bottom that prevent mounting it at an angle. Just name the technique and I’ll look it up.

1 Like

I think this is not the first time the Mill DRO malfunctions have been mentioned

As far as I know, it is still broken. Can’t personally answer your second question, though.

I would spin the vise and square it back up when you’re done if you’re feeling generous. Squaring the vise was covered in the mill class; it’s probably unwise in general to assume it’s square when you walk up to the machine.

Whatever you do, don’t leave it almost square – if you don’t square it properly, leave it obviously off so the next user won’t assume it’s still square.


The DRO is trash. I cleaned it and it was still flaky

1 Like

Thank you sir.