General Fusion 360 Question

I’ve been teaching myself Fusion so that I can use it for my CnC needs. Designed a couple of things and tried to create them on the Small CnC today. It simulates fine in Fusion, and I have Autodesk Generic 3 Axis selected as the machine along with the post process from Laguna for the IQ /Swift.

However it starts and just goes to the first point and then does nothing but spin. Am I missing something critical? Luckily I also created the part I needed in VCarve, and that worked fine.


1 Like

Are you post processing in Metric?

#griff0527 I’ve done a lot on a Shark maching using Fusion360 a few years back and I found that Aspire 9.5 works well on the 3D modeling. It’s been like 3 years but my memory is that you can download a trial version and if you do some research find a version to clone for very little money on Ebay to get access to it. VCarve makes the code and there may be better versions today but it’s pretty useful for two sided 3D models. I can share what I know.

I just did the same thing, created my first fusion model and tried to cut it. That was I all I did, Generic 3 axis + Laguna post + use metric. Worked for me.

When you do the post, you have to select laguna each time (at least that is the case for me). If you don’t I think it just uses “autodesk simulator”, an just generates and empty file. If you open up the MMG file, is it empty?

No, it was set to imperial. Lol, so it all has to be metric? that’s crazy :slight_smile: I mean I’d love everything to be metric but wouldn’t expect it to be for Laguna. Metric makes me have to convert things constantly, I try to do as little math as I possibly have to.

I am not sure if the model has to be metric, just that you select “use metric” in the post. I think my model had a mix of metric and imperial.

You can design in imperial. But you have to post in Metric.

1 Like

Yeah I caught that, so I was watching for it, and I just double checked and the file was not empty. I dunno, it’s weird. I was hoping there was some extra undocumented “thing” I needed to do on the machine setup or something, guess it’s just magic. I’ll take my laptop up there next time ad just try a simple rectangle or something until I figure it out.

Ahh, ok… that’s probably it…

I had this exact same problem, posting to metric is the solution

1 Like

Just a update for future people with the same issue. Changing the post to millimeters was the trick for me too. By default the post sets itself to “Document Standard” probably so it just inherits from whatever you designed the part with, in my case that was imperial, so I suppose if you started with metric to begin with you wouldn’t run into the issue.

It so strange that a high tech piece of equipment wouldn’t want to accept units based on 1/12th of the King’s foot :wink:

1 Like

Lol, I run into this sort of thing all the time in my day job. This is basically a lazy programmer problem. I’m guessing that Fusion 360 isn’t the problem here. It is probably the person responsible for writing the Laguna Post Process (which is on Laguna). When they were writing it, they “could” have made sure that the post process worked for both Imperial and Metric, but they chose to just support metric. Math is hard :slight_smile: Just Metric is easier, and it’s probably what the majority of Laguna’s customer base actually uses.

Funny thing is, it probably generates a ton of customer service requests for Laguna, so they end up paying for it anyway.