Error: Radius to end of arc differs from radius to start

Has anyone seen and over come this error in LinuxCNC?

“Radius to end of arc differs from radius to start”

I am using Fusion 360 and have over come this is the past by turning up the tolerance. But not today, I spent two hours trying to everything google would throw at me and nothing worked.

You can turn arcs off in Fusion. I’m reading through and old thread on the old email forum about arcs and the error.

@r1b4z01d try this:

Yep known Fusion 360 bug. There is a postprocessor for Fusion 360 to fix this

Thanks @JoeN for the info but I have tried all of that. I tried multiple versions of post processors, disabling arc, changing the tolerances. I have tried multiple types of cutting methods. I modified the ini to attempt to change the tolerance. That did not solve the issue to I removed my changes.

I have manually edited the post processor and disabled arcs. Now I am getting “arc radius too small to reach endpoint”. Off to googling to see if I can resolve this.

@dannym Do you have any additional information to back up that claim? From my understanding it is a bug in LinuxCNC. The tolerances are hard coded and do not use the value in the the INI file. They state they fixed the issue in 2.7.0 and we are running 2.7.4 but the ini file does not include the variables. When the variables are added to the INI they do not seem to be solving the issue. ¯_(ツ)_/¯

2.8.0 was released earlier this year do we plan to update?
2.7.4 was released inn 2016 :grimacing:
Is there still a copy of VCarve install on a computer here?

I ended up installing Aspire on a VM to get the job done. Any idea why circles are not being cut evenly? I tried rehoming the machine. I verified the X rails are both even. Anything else I could try?

I think it was the x axis. I did the trick where you have it hit the end stops, then I re-homed and it seems to be much better.

Cool, glad the distortion is fixed.

To answer one of your earlier questions: Yes, multiple versions of VCarve Pro are installed on the lounge computer near the arcade cabinet. (The computer itself is cleverly hidden in a cabinet below the counter.)

FWIW, I used VCarve 10.5 they last night to generate some basic toolpaths with no issues. Thanks to Danny for getting that set up. The new auto-chamfering toolpath feature is pretty slick.

I had this issue with F360 for a while. I played around with a bunch of things and found the lead in arc for bore/spiral toothpaths to be the cause of my problems. I also never got the 2d face function to work and ended up making it work with adaptive clearing and adjusting height. I can appreciate how much of a pain it is when you do all the design, rock up to get started and find out nothing works : (

The x axis looses steps and creates tension in the gantry. Every time we use the cnc router. The check if the gantry is square relative to the end stops should be done. It is a good habit to check

The x axis looses steps and creates tension in the gantry. Every time we use the cnc router

It is not capable of losing steps. It can be stalled entirely if jammed, but that’s not subtle at all.

Racking comes in only when it’s been powered off. The 2 gantry motors are freewheeling and if you just push on it, one side will move without the other.

You can loose steps in any system with 2 motors. Whether the steppers are stalling or the belts jump teeth. The end result is you have an un-square gantry. Best practice is to check the squareness against the end stops before every use. I have hardly ever turned on the machine and the gantry be perfectly square. It is part of the cnc life to home your machine and check reference.