Epoxy cap giving me trouble

I’ve got this JB Weld epoxy, and can’t for the life of me get the cap off. Is there a trick I’m missing?

Hmm, is it new or used? Perhaps some epoxy cured keeping the cap on. At the risk of being obvious, did you try twisting before pulling?

I have the same, but I think it has a slightly different cap

When that’s happened to me (on partial tubes) I just break out the big pliers and resign myself to the package no longer being resealable.

1 Like

It has been used once, and so this is the “removable cap”. I have twisted, tried to slide, and tried to push it at an angle. I can’t see where to get a screwdriver in to use like a lever. I’ll keep trying for a bit before going for the nuclear route

It would be less irritating if it had been used more times. Of course if that were true, it would probably imply I already knew how to get the cap off

Broke out the magnifying glass and found the teeny tiny slot for a screwdriver. Success


Haha good luck! I’ve actually never seen a JB Weld cap like that – is it especially new or old? All of the ones i’ve seen are more like this
edit: nevermind, i see its a smaller one and the cap pops out of the handle. Glad you got it sorted!

This tube is at most 6 months old. So new-ish.

1 Like

Ah…the smell of epoxy in the afternoon