CNC Z-Axis probe tool not working

I feel terrible, but I speared the DT02 Z-Axis probe last night. As a result, I could not get it to work (no surprise). I labeled it and put it in the drawer after removing the batteries. I tried the other sensor, but it looks like it needs the matching receiver? I was able to use the machine perfectly fine using the Macro/paper method (learned from the great CNC class).

Anyway, I will be happy to replace the probe. I found what I believe to be the exact one on Amazon for 65$ but I’d like one of the experts to advise on the exact one they want/need, and how to get it delivered/installed.


It happens. I wish the probe was wired. I feel the that wired is sort of bulletproof. The wireless probe has a very low failure rate. I would talk to @Danny prior to ordering. Glad you got it sorted with the tried and true paper method.

I was guilty of this too, which is why there is a replacement probe in the drawer. I believe when I purchased the replacement, Danny and I decided not to wire it in for a few reasons, mainly the old one was still functional.
Unless I’m mistaken the new probe in the drawer is still a viable option, and just needs to be wired in, if it is decided to use it. @dannym would know more about this, and if you need to purchase a replacement.

I may be in the minority but I tend to use the paper method all the time, not just when the probe is out of commission. Maybe it comes from my 3D printing experience where you’d have to level the bed all the time, but there’s something about actually seeing and feeling where zero is.

I’ll take a look.

The replacement probe, while it looks very similar and labeled “DT02”, is a different build and that one just didn’t work consistently. The aluminum plunger’s slide is very tight and draggy and tends to hang in the plastic bore when extending. The spring has to be light to be safe to work with the very fine-point, fragile bits, so we can’t strengthen the spring.

I tried working it up and down for a few minutes, thinking it might rub off a plastic burr or whatever, but it didn’t change. Lubrication’s not a great option as it’s in a dusty environment and if it mucks I don’t see how it could ever be cleaned where it’s at. I assumed this would be easy to disassemble, somehow loosen the plunger in its bore, and be as excellent as the earlier probe. I don’t recall the details but there was some sort of problem with the way the plunger is retained that made it difficult to take apart in a way that was amenable to being put back together. We can take another stab at it, though.

I don’t know if another Amazon probe will be different. Maybe, this one could just be a bad batch. It wouldn’t make sense for them to keep making probes that can’t extend correctly.

Several cases for damage came from leaving the spindle running with the bit in it. I could add some code to force the spindle off if it’s on, but that won’t guarantee the spindle spins down to 0 RPM before probing. There’s no condition like that in the VFD’s interface into LinuxCNC. Maybe the better condition would be that if the spindle is running, abort the probe cycle entirely, that does make sense.

I believe after working the plunger, and heating the metal with your lighter, the plunger started working better. I thought you got it to a more acceptable standard.
If you still think its to stiff, I’d be happy to buy another one to see if it was just a bad product. Now that I’m thinking about it, I believe the other difference was an extra wire on the remote sensor. Also I believe we weren’t the biggest fan of the bottom of the probe, as it had a lip that extended past the metal base.

Yep both those. I don’t think it got all that looser in the bore by working it. The receiver box has a different gender on the wire’s pins on the new style.

How bad is the “speared” one? I’m not clear what that means. We ordered a replacement when the first one got a bit literally broken in it, but actually that came out and the surface smoothed out ok and, as abused as it looks, really hasn’t been a problem.

1 Like

I’m with you. Team Paper!


Actually, now that I think about it, I’m not sure if it may still work, the battery light came on, so I assumed it was dead. But when I put the batteries in the other one, it did the same thing (battery light on). Maybe it just needs new batteries and the timing was coincidental?

Any updates on this? Also the pendant knob seems to be broken when spinning counterclockwise. It seems to register both a forwards and backwards movement. Helps if you push down on the knob.

The tool probe was fixed that day, it’s fine. The pendant prob sounds new, I’ll take a look

I saw the same behavior as Ian and noticed the low battery light was blinking on the handheld. I replaced the batteries and it seems to be behaving better