CNC Pendant not working

The Pendant for the CNC is not working. when I push the silver button in the top right corner, the LCD display (sometimes) flashes briefly, and the battery light flashes briefly, but then there is no further action.

I tried replacing the batteries with new ones, but no improvement. Also tried checking for dust/corrosion in battery compartment (there was none) , tried holding down the silver button for a few seconds, and gently pushing the silver button halfway down. No luck.

Thank you very much for any advice on this.

Louis Fuka

The PC must be on first, or the LCD will come on briefly then go out, waiting for the PC

Both the Linux and Windows PCs were on

Based on Danny’s reply, I suspect I did something wrong – not booting the PCs up correctly, or something like that. I am a newbie at CNC, so the most probable cause is user error on my part.

Thank you Danny for this information.

I had the same issue yesterday - the pendant would flash but not maintain a lit screen even after changing the batteries, restarting the computer and CNC, rehoming, etc. Maz and others also looked at it and none of us could get it to work.

When restarting the computer an error message came up about not being able to connect to the pendant so maybe it is something with the wireless connection between computer and pendant??

I opened a red tag issue about this BTW

It’s on a wireless USB dongle . The gold-taped USB stick on the back of the kiosk, near the top, is the USB dongle. It’s likely been unplugged from USB.

I checked that; it was fully plugged in.

I wonder if the issue is the usb antenna needs to disconnected and then reconnected? Or if the new nuc is shutting down the port to save power?

The USB extender cable it’s on is flaky.
I put the dongle stick on the NUC computer USB port directly, it works ok it’s just sticking out a lot and at some risk of being knocked and broken off.


FYI you can operate entirely from the keyboard too.

The key function to know is the “Touch Off” button, along with the radio buttons for X/Y/Z/A axes. The axis knob position on the MPG is irrelevant here, it will use the radio button selection.

“Touch Off” prompts you to enter the next value for the current selected axis as per the radio buttons, defaulting to 0. If you enter “0” it’s the same thing as the “=0” button on the MPG. You can also enter nonzero values here, which you can’t do on the MPG.

This used to be the best way to lower the place the Z axis cuts to if it doesn’t 100% cut through the first time. However, that’s been superseded by the “Macro 3” button which just numerically raises the Z coord by 0.05", which makes it physically cut 0.05" deeper. One press should be enough to finish most partial cut-throughs.

1 Like

Thank you for that info. That, plus changing the jog rate to move more precisely, would let someone keep working even without the pendant (though it would definitely be much less convenient).

@dannym Ran the CNC this morning. No issues with the pendant however there were 3 times linux CNC turned off mid program and stated Joint 4 following error (3 times) and Joint 0 following error (2 of 3 times). This occurred at random points in different programs. Each time it shut off I just rehomed and started the program over and it worked fine until another occurrence happened.

Ok that is something we can and should address, I must say I’m surprised to hear this but it’s likely simple to fix.

Can you take a pic when it happens? The exact message in the lower right hand corner is very important.

1 Like