CNC feed rate issue

I may be missing something simple but it seems like someone preset an extremely fast feed rate as the default on the remote. The machine seems to be ignoring my feed rate from my file and I’m having to manually slow down once started. Any ideas?

Is there something in the remote set to override the file settings?

Afaik (which is limited)…. You can slow the machine down from your file’s settings via the remote - but you can’t speed the machine up above 100% of what’s in the file…. That may have changed - or there is a hack I don’t know about.