Canon iPF5100 Large Format Printer

I wonder if there’s anybody who can help me to bring our Canon iPF5100 back to life?
At first, I was getting a message about the lack of ink. So I changed all the empty cartridges and now am getting another issue - paper mismatch
Have no clue what I’m doing wrong. I checked all the settings on my laptop, tried both glossy and matte paper rolls - still no luck
It even wouldn’t print test print page
As far as I’m aware, it is a pretty old model so it’s not easy to find decent and easily understandable sources for troubleshooting this thing online
So if anybody knows how to make this thing work - any suggestion would be highly appreciated
Thank you

the Canon docs I could find suggest that error means the settings on the printer and the settings on the driver don’t agree with each other, not anything wrong with the paper itself. There’s probably a settings menu buried on the printer that allows you to say what kind of paper’s loaded, but the printer doesn’t support telling the driver.

If that doesn’t help, try cleaning the paper path as best you can. just wipe things that touch paper with a slightly damp cotton rag. There could be a grotty sensor.

After that… you’re on your own. let us know how it goes :slight_smile:

Is there a self-test function on the front panel? Normally there is a magic combination of buttons that will make the printer eject a test page regardless of settings.

At least that would allow you to verify that the printer, itself, is functional.

I’ve been working on the printer off and on as well. The ink cartridges were my first hold up, didn’t realize we had replacements up there. I did work on it some more tonight.

My observations so far.
-The mismatched paper doesn’t seem to stop the printing. I printed a few trials, even with the error.
-The print heads do seem to be clogged. When you print a nozzle check from the printer, only about 3 inks show up on the right side, and none from the left. I was doing “print head b” cleanings, and it was getting better, but I ran into a maintenance cartridge full error.
-I believe there is a manual way to clean the print cartridges, but with the maintenance cartridge error, the print head replacement and nozzle cleaning functions are locked out.
-From the few test prints I was able to do, it seems like the printer is functional and trying to print, loads paper and cuts it to size after the print.

I’d like to continue to work on this project, and hopefully get it back to functional status.

Is the maintenance cartridge something the space would provide, or is that on members? It costs about $70, and seems to be the next required part to continue resurrecting the printer.

Tagging @valerie. @EricP

1 Like

I’ll buy this one but really it’s on members to bring there own cartridges. The point of the ink thats there is for us to use for making signs and stuff for the space not for personal projects.

Thanks Eric. I hope we can continue to get this printer fully functional.