Fusion360 & the CNC routers compatibility

I recently took the CNC class with @dannym and he showed us the in’s and outs of getting started with VCarve and Linux CNC. In passing he mentioned that we were free to use other programs for modeling and cam, but that VCarve was kind of the simplest to get bootstrapped onto.

Well I’m much more familiar with Fusion360 and SolidWorks. I was wondering if there were any special considerations someone has to take when they’re taking a design/model from Fusion and trying to get it cut with the router? Is there known post processors that should be used? Or is there a particular “machine” we can target when trying to generate the GCode?

A separate and unrelated question is if the smaller CNC Machine is operational, and if so is it running Linux CNC as well? I forgot to ask during our class and we only focused on the 5x8.

1 Like

Can’t answer your first question, besides the fact that you could design in Fusion if you’re more comfortable and export sketches as vectors and design just the toolpaths in VCarve. Fusion CAM is much more complicated and feature rich which can end up just causing confusion for a simpler router. I know some people have successfully gotten it to work though.

As for the second, yes the Shark CNC is up and running, and there is a separate course for that (much less intensive than the first one) to get you up to speed on some of the major differences. Not sure if there is anything on the schedule though.

1 Like

Fusion 360 is a very viable option to use. I know a few members use it, I dont personally use it though. Taggi g a few people I can think of, that might have better answers.
@MMcATX @CLeininger @JoeN


The smaller cnc does not run linux cnc. It uses the software supplied by Shark. It is a windows machine. It is very easy to learn. It also has vcarve installed so it is a quicker transition from cam to cut.

The main advantage of Fusion is testing fitment of assemblies. Also the parametric design is nice. All of the smoothness of Vcarve is setup by you in Fusion such as the thickness of your stock vs the actual final dimension. You will have to setup your tool library. The toolpath options are better for more control of your cut. It is also easier to setup a contoured cut such as a guitar body with compound curves. I can’t remember the post processor for linux cnc.

1 Like

Just as a reference, you’re able to target machines, or identify specific post processors (3rd party).

1 Like

I started with VCarve but now use Fusion almost exclusively for CAM since I also design in Fusion. Exporting to VCarve is doable but a pain, especially if you are designing iteratively.

I don’t bother selecting a machine for Asmbly’s CNC, and instead select Enhanced Machine Control (EMC) for my post processor.

Keep in mind X and Y are backward from convention on the large CNC so either orient your design or change your coordinate XY zero accordingly.

Don’t use the tool change function as apparently linux doesn’t play nice with the tool change gcode. Save different tools as different ngc files.

Otherwise, AFAIK everything else is standard. Just make sure you set your tool heights so you don’t accidentally plunge down into the spoil board. A few thou or .1 mm is really all you need for a through cut, assuming you’ve set your material thickness correctly.

Fusion CAM is significantly more complicated than VCarve but also significantly more capable. Just depends on your needs and how much time / effort you want to put into learning the workflow.

1 Like

Perhaps a very stupid question… but how do I select EMC?

Not a stupid question at all. I would never have figured it out without help from @MMcATX.

When you post process the tool pathing, open the folder next to Post under Machine and Post. Scroll down to LinuxCNC in the Fusion 360 library. There are a few different options. Select Enhanced Machine Controller (EMC).


I am happy to help where I can! Shoot me a email/PM if you like. Also see this post about a mod to the post processor code i found helpful: Modifications to Linux post processor in F360 for multi-tool jobs

1 Like

Just anyone who stumbles on this thread;

I attempted to run a simple part to exercise the workflow and the machine would stop on the line:

N45 Z0.6

Here’s the full GCode:

(T1  D=0.25 CR=0. - ZMIN=-0.77 - FLAT END MILL)
N10 G90 G94 G17 G91.1
N15 G20
N20 G53 G0 Z0.
N25 (T1 M6)
N30 S18000 M3
N35 G54
N40 G0 X-0.1503 Y1.1908
N45 Z0.6
N50 G1 Z0.2 F50.
N55 Z0.125 F16.667
N60 Y1.1905 Z0.1211 F50.
N65 X-0.1502 Y1.1896 Z0.1173
N70 X-0.15 Y1.1881 Z0.1137
N75 X-0.1498 Y1.1861 Z0.1103
N80 X-0.1495 Y1.1835 Z0.1073
N85 X-0.1492 Y1.1806 Z0.1048
N90 X-0.1489 Y1.1772 Z0.1027
N95 X-0.1485 Y1.1736 Z0.1012
N100 X-0.1481 Y1.1698 Z0.1003
N105 X-0.1477 Y1.1659 Z0.1
N110 X-0.1451 Y1.1411
N115 G3 X-0.1176 Y1.1188 I0.0249 J0.0026
N120 G2 X0.1176 Y-1.1188 Z-0.0875 I0.1176 J-1.1188 F16.667
N125 X-0.1176 Y1.1188 Z-0.275 I-0.1176 J1.1188
N130 X1.125 Y0. Z-0.375 I0.1176 J-1.1188
N135 X-1.125 I-1.125 J0. F50.
N140 X1.125 I1.125 J0.
N145 X-0.0941 Y-1.1211 Z-0.4737 I-1.125 J0. F16.667
N150 X-1.1092 Y0.1876 Z-0.5725 I0.0941 J1.1211
N155 X1.1092 Y-0.1876 I1.1092 J-0.1876 F50.
N160 X-1.1092 Y0.1876 I-1.1092 J0.1876
N165 X0.2798 Y1.0897 Z-0.6713 I1.1092 J-0.1876 F16.667
N170 X1.0624 Y-0.37 Z-0.77 I-0.2798 J-1.0897
N175 X-1.0624 Y0.37 I-1.0624 J0.37 F50.
N180 X1.0624 Y-0.37 I1.0624 J-0.37
N185 G3 X1.0778 Y-0.4018 I0.0236 J-0.0082
N190 G1 X1.1014 Y-0.41
N195 X1.1051 Y-0.4113 Z-0.7697
N200 X1.1087 Y-0.4126 Z-0.7688
N205 X1.1121 Y-0.4138 Z-0.7673
N210 X1.1153 Y-0.4149 Z-0.7652
N215 X1.1181 Y-0.4158 Z-0.7627
N220 X1.1205 Y-0.4167 Z-0.7597
N225 X1.1225 Y-0.4174 Z-0.7563
N230 X1.1239 Y-0.4178 Z-0.7527
N235 X1.1247 Y-0.4181 Z-0.7489
N240 X1.125 Y-0.4182 Z-0.745
N245 Z0.6
N250 G53 G0 Z0.
N255 G53 G0 X0. Y0.
N260 M30

I use solidworks, so you don’t have to just use VCarve…

The GCode looks pretty simple… Did you have any messages on the bottom-right? Did the spindle spin up?

1 Like

You didn’t mention an error message, so I’m guessing it just stops and waits there?

My guess is it’s not the N45 line, but N50, which contains the first G1, an actual cut.

The CNC will not perform a cut until the spindle is running at speed. It can go G0 rapids, but will wait for the spindle to come up to speed before starting a G1 cut. If you didn’t turn on the spindle, it’s going to just wait indefinitely.

Did you turn on the spindle power?

This wouldn’t be anything related to Fusion 360.

1 Like

Clearly, my ignorance is on full display. I did not turn on the spindle power.

I was under the assumption that the program was supposed to turn the spindle on. Is that an incorrect assumption? I understand that we manually engage the spindle if we’re “running from here” and it doesn’t have a chance to read the start spindle command.

N30 S18000 M3

I was following the document/booklet that was in the CNC drawer and from what I could tell I flipped on all the switches that were outlined. I groked around the spindle and the power cord for a switch but it all disappears into the cable carrier.

On my way out I was talking to a gentleman and told him that I couldn’t get the spindle to turn on manually. He pointed out the “Spindle” button on the remote which was supposed to turn it on. I was trying to make it spin from the “Manual Control” panel in the Linux CNC program.

That’s good to know. And makes a lot of sense.

The spindle is turned on and off in software by the G-code (M3), but the red and yellow rotary knob on the left of the router is the actual power switch for the Variable Frequency Drive that turns the spindle and that has to be powered first.

1 Like

Thanks Danny.
I’ll try again tomorrow.

Perhaps not relevant since i used vcarve to generate my gcode but I had issues the other day with the spindle refusing to start on my third gcode path after a few hours of running ok. I just tried resetting a ton of stuff until it worked- i think I had to press the reset vfd on the right but not sure that that was necessarily the fix, since i don’t know what vfd stands for, but i guess its variable frequency drive

1 Like

After a little bit of trial and error, I was able to get it working.
Just FYI the controller box under the table was unplugged for some reason. I don’t know if you’re supposed to unplug it when you shut it down, but I left it plugged in.

1 Like

It shouldn’t be unplugged. It should be turned off via the power switch. The spindle should also be turned off

Yeah, I turned off the spindle. But left the box plugged in.

1 Like